FI OP PSD2 APIs service disruption

Incident Report for Mastercard OB Services EU and UK

Resolved

At 10:39 (GMT+1) we recognised service disruption on OP PSD2 APIs and customer channels
Posted Mar 05, 2025 - 09:01 UTC

Monitoring

At 10:39 (GMT+1) we recognised service disruption on OP PSD2 APIs and customer channels
Posted Mar 04, 2025 - 10:16 UTC