PKO BP Login Redirect Issue

Incident Report for Mastercard OB Services EU and UK

Resolved

Provider fixed the issue on their end.
Posted Mar 30, 2026 - 15:40 UTC

Investigating

We are currently aware of a problem where some users are being redirected to an incorrect login screen when attempting to access online banking.
Posted Mar 30, 2026 - 14:46 UTC
This incident affected: Providers (Poland).