A service disruption has been completely resolved for Mastercard Open Finance systems in the Europe region. Customer impact began on 4 Dec 2025, 04:12 UTC and was completely mitigated on 4 Dec 2025, 04:35 UTC.
Posted Dec 04, 2025 - 05:06 UTC
Monitoring
We are observing service recovery across Mastercard Open Finance systems in the Europe region. Monitoring confirms that impacted flows are gradually returning to normal operation. We will continue to observe system stability and provide a final update once full recovery is verified.
Posted Dec 04, 2025 - 04:59 UTC
Investigating
A service disruption has been identified for Mastercard Open Finance systems in Europe region. All the products are impacted. Mastercard teams are investigating this issue and will provide an update as soon as possible.
Posted Dec 04, 2025 - 04:34 UTC
This incident affected: Aiia Enterprise (Account information services, Payment initiation services), Aiia (Aiia Pay, Aiia Data API), and Payment Products (Accept Payment).