Outage on all call types with Samlink based providers in Finland

Incident Report for Mastercard OB Services EU and UK

Resolved

We are experiencing an outage with Samlink based providers in Finland. All call types are affected. Affected providers: Oma Säästöpankki, POP Pankki and Säästöpankki.
Posted Oct 27, 2025 - 12:24 UTC

Monitoring

We are experiencing an outage with Samlink based providers in Finland. All call types are affected. Affected providers: Oma Säästöpankki, POP Pankki and Säästöpankki.
Posted Oct 26, 2025 - 01:38 UTC