FI_Op planned maintenance
Scheduled for Feb 8, 20:00 UTC  -  Feb 9, 06:00 UTC
Update
Due to maintenance work, you may experience intermittent access to PSD2 APIs. 08/02/2025 9:00PM CET - 09/02/2025 7:00AM CET
Posted Jan 23, 2025 - 07:42 UTC
Scheduled
Due to maintenance work, you may experience intermittent access to PSD2 APIs. 08/02/2025 9:00PM - 09/02/2025 7:00AM
Posted Jan 22, 2025 - 10:03 UTC
This scheduled maintenance affects: Providers (Finland).