Observing issues with N26

Incident Report for Mastercard OB Services EU and UK

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2026 - 10:17 UTC

Update

We are continuing to investigate this issue.
Posted Jul 08, 2026 - 07:56 UTC

Investigating

We have observed failed calls with N26. Currently under investigation
Posted Jul 08, 2026 - 07:46 UTC
This incident affects: Aiia Enterprise (Account information services, Payment initiation services), Aiia (Aiia Pay, Aiia Data API, Aiia Data Sync), Payment Products (Accept Payments), and Global Platform (Global Data).