Missing transactions in Nordea

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 13:36 UTC

Update

We continue working on this issue.
Posted Mar 18, 2025 - 12:36 UTC

Monitoring

We continue to monitor the issue and are in contact with Nordea to solve it.
Posted Mar 10, 2025 - 10:39 UTC

Investigating

We are still experiencing the issue. We continue to investigate and are in contact with Nordea to solve the issue.
Posted Mar 05, 2025 - 15:45 UTC

Monitoring

Nordea released the fix for this issue.
Posted Mar 05, 2025 - 09:57 UTC

Investigating

We are experiencing a problem with some missing transactions from Nordea accounts. This is due to a deduplication mechanism that encounters repeated transaction IDs. We are in contact with Nordea to explain and solve this issue.
Posted Feb 26, 2025 - 12:52 UTC
This incident affected: Providers (Denmark).