Delayed global data webhooks

Incident Report for Mastercard OB Services EU and UK

Monitoring

We have observed delays in global data webhooks delivery. Customers may experience delayed synchronization of open finance data as consequence

Issue has been mitigated, currently monitoring.
Posted Jul 21, 2026 - 06:33 UTC
This incident affects: Global Platform (Global Data).