Elevated error rates on account information and payment calls with OP in Finland

Incident Report for Mastercard OB Services EU and UK

Resolved

We are seeing elevated error rates affecting most calls with OP in Finland. Account information and Payment calls are affected.
Posted Nov 03, 2025 - 15:29 UTC

Identified

We are seeing elevated error rates affecting most calls with OP in Finland. Account information and Payment calls are affected.
Posted Nov 03, 2025 - 15:06 UTC