Observing issues with Luminor

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 07:41 UTC

Investigating

We have observed failed calls with Luminor bank. The failures are limited to Luminor bank, and the bank has been unavailable since 18/08/2026 03:00 UTC
Posted Aug 18, 2026 - 06:53 UTC
This incident affected: Providers (Estonia, Latvia, Lithuania).