Elevated number of failed requests on OP in Finland

Incident Report for Mastercard OB Services EU and UK

Resolved

Starting at 9:55 CET, we are seeing an increased number of failed requests for OP in Finland.
Posted May 15, 2026 - 09:03 UTC

Update

Starting at 9:55 CET, we are seeing an increased number of failed requests for OP in Finland.
Posted May 15, 2026 - 08:19 UTC

Identified

Starting at 7:55 CET, we are seeing an increased number of failed requests for OP in Finland.
Posted May 15, 2026 - 08:19 UTC