Elevated failed payment rate with CrossKey based providers in Finland

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved. We have observed elevated error rates between 09:45 and 10:54 UTC on 2026-02-25
Posted Feb 25, 2026 - 11:44 UTC

Monitoring

We see elevated rates of failed payments with many users affected on CrossKey based providers in Finland
Posted Feb 25, 2026 - 10:48 UTC
This incident affected: Providers (Finland).