Service degradation affecting PIS requests

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 23:42 UTC

Investigating

Service degradation affecting PIS requests - we are investigating the issue.
Posted Apr 24, 2026 - 23:24 UTC
This incident affected: Payment Products (Accept Payment).