SEB Baltics elevated error rated to PSD2 Payment services

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 11:04 UTC

Monitoring

There are disturbances in Baltics SEB from 12:56 (09:56 UTC), which affects the redirect flow in Payments.
Posted Aug 12, 2026 - 10:22 UTC
This incident affected: Providers (Estonia, Latvia, Lithuania).