S-Pankki degraded performance

Incident Report for Mastercard OB Services EU and UK

Resolved

S-Pankki is experiencing an issue affecting the performance and reliability of the services. Some users may encounter slower response times, intermittent errors, or reduced functionality. The engineering team is actively investigating the root cause and working to restore normal service levels as quickly as possible.
Posted Aug 04, 2026 - 09:39 UTC

Investigating

S-Pankki is experiencing an issue affecting the performance and reliability of the services. Some users may encounter slower response times, intermittent errors, or reduced functionality. The engineering team is actively investigating the root cause and working to restore normal service levels as quickly as possible.
Posted Aug 04, 2026 - 07:45 UTC