Elevated error rates on All call types with Nordea and Nordea Yrityspankki in Finland, Denmark, Sweden and Norway

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved by a provider at 1:26 CEST.
Posted May 30, 2023 - 07:04 UTC

Investigating

We are seeing elevated error rates affecting many calls with Nordea and Nordea Yrityspankki in Finland, Denmark, Sweden and Norway since 19:11 CEST. All call types are affected. We are contacting the provider.
Posted May 29, 2023 - 18:22 UTC
This incident affected: Providers (Denmark, Sweden, Norway, Finland).