Service event for European Payment Platform

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 14:07 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 16, 2025 - 13:57 UTC

Identified

On 16 October 2025, Mastercard teams identified a service event for European Payment Platform impacting the Europe region. During the impact window, customers are experiencing API calls failure with 503 service unavailable message while accessing Authorization Service. The root cause was attributed to a certificate expiration at infrastructure level. The issue is currently active and team is working on mitigating it.
Posted Oct 16, 2025 - 13:44 UTC
This incident affected: Aiia (Aiia Pay).