Elevated error rates on all call types with Wise based providers

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 16:28 UTC

Identified

Due to maintenance work on provider side we are seeing elevated error rates affecting all calls with Wise based providers across all markets. All call types are affected.
Posted Dec 16, 2025 - 16:10 UTC
This incident affected: Providers (Denmark, Sweden, Norway, Finland, Germany, Great Britain).