DanskeBank Finland - Major outage

Incident Report for Mastercard OB Services EU and UK

Resolved

The issue has been resolved on the Provider's side.
Posted Aug 16, 2026 - 10:26 UTC

Investigating

We are seeing major outage affecting calls to Danske Bank Finland. The issue started around 09:00 and we are currently investigating it.
Posted Aug 16, 2026 - 08:57 UTC
This incident affected: Providers (Finland).