Elevated error rates on all call types with N26

Incident Report for Mastercard OB Services EU and UK

Identified

The issue has been identified at the provider side
Posted Sep 16, 2025 - 14:40 UTC

Investigating

Since yesterday 2025-09-15 morning we are seeing elevated error rates affecting any calls to N26

We have contacted the provider and are currently investigating the issue
Posted Sep 16, 2025 - 10:38 UTC