Elevated error rates for Swedbank

Incident Report for Mastercard OB Services EU and UK

Resolved

Swedbank traffic fully returned to normal patterns.
Posted Jul 11, 2026 - 10:40 UTC

Update

We see signs of recovery, we continue to monitor the results.
Posted Jul 11, 2026 - 04:57 UTC

Monitoring

We have observed failed calls with Swedbank. Currently under investigation.
Posted Jul 11, 2026 - 04:55 UTC

Investigating

We have observed failed calls with Swedbank. Currently under investigation.
Posted Jul 11, 2026 - 04:49 UTC