SSL certificate issue

Incident Report for Mastercard OB Services EU and UK

Resolved

Incident resolved, traffic restored
Posted Feb 23, 2026 - 14:33 UTC

Investigating

After a domain change in our internal infrastructure we have detected an increase rate of errors in SSL resolution.

We are reverting the change
Posted Feb 23, 2026 - 14:25 UTC
This incident affected: Aiia Enterprise (Payment initiation services).