Decreased performance for Comdirect

Incident Report for Mastercard OB Services EU and UK

Monitoring

The provider has released a fix and conversion rate is recovering. We are currently monitoring
Posted Sep 23, 2026 - 07:28 UTC

Investigating

Starting 16th September, we have identified a decrease in conversion rate for Comdirect affecting some customers. We are currently investigating and have contacted the provider to address the issue
Posted Sep 22, 2026 - 09:00 UTC
This incident affects: Providers (Germany).