Elevated number of failed requests on Payment area with OP in Finland

Incident Report for Mastercard OB Services EU and UK

Resolved

Increased number of failed requests on Payment area for OP in Finland resolved at 11:55 CET.
Posted May 18, 2026 - 11:23 UTC

Monitoring

Starting at 9:15 CET, we are seeing an increased number of failed requests on Payment area for OP in Finland. This may affect payment authorization requests.
Posted May 18, 2026 - 08:27 UTC