FI Samlink PSD2 payments are experiencing interruptions

Incident Report for Mastercard OB Services EU and UK

Resolved

FI Samlink PSD2 payments are experiencing interruptions starting from 10:20AM UTC
Posted Mar 13, 2026 - 10:54 UTC

Investigating

FI Samlink PSD2 payments are experiencing interruptions starting from 10:20AM UTC
Posted Mar 13, 2026 - 10:30 UTC
This incident affected: Providers (Finland).