Elevated failed payment rate with Samlink based providers in Finland
Incident Report for Aiia
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 12:31 UTC
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 11:41 UTC
Investigating
We see elevated rates of failed payments with most users affected on Samlink based providers in Finland
Posted Apr 18, 2024 - 11:01 UTC
This incident affected: Providers (Finland).