Degraded Performance of payments for Nordea provider in Denmark

Incident Report for Mastercard OB Services EU and UK

Identified

We are getting Bank Service Unavailable from Nordea.
Posted Sep 03, 2026 - 17:50 UTC

Investigating

We are currently investigating this issue.
Posted Sep 03, 2026 - 17:38 UTC
This incident affects: Aiia Enterprise (Payment initiation services).