DeutscheBank facing intermittent issues with AIS and PIS

Incident Report for Mastercard OB Services EU and UK

Resolved

DeutscheBank
PSD2 APIs – Due to an issue from one of our backend services we are facing intermittent issues with AIS and PIS requests for all region since 11:30 AM CET on 11th September 2025.

Update : Services are back to normal since 12:06 CEST
Posted Sep 11, 2025 - 10:50 UTC

Identified

DeutscheBank
PSD2 APIs – Due to an issue from one of our backend services we are facing intermittent issues with AIS and PIS requests for all region since 11:30 AM CET on 11th September 2025.
Posted Sep 11, 2025 - 10:25 UTC