Outage in payment journeys in aiia pay

Incident Report for Mastercard OB Services EU and UK

Monitoring

The issue was attributed to a caching issue with our cloud provider. Manual intervention has resolved the stale cache issues and the system is restored. We are monitoring for any remaining issues.
Posted Jun 03, 2026 - 11:43 UTC

Investigating

We have detected an high number of payment journeys failing in aiia pay flows. Currently investigating
Posted Jun 03, 2026 - 10:09 UTC
This incident affects: Aiia (Aiia Pay).