We are experiencing payments flow failures on EPP

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 11:45 UTC

Update

We are continuing to investigate this issue.
Posted Feb 12, 2026 - 11:32 UTC

Investigating

Mastercard teams are investigating the impact and RCA
Posted Feb 12, 2026 - 11:18 UTC
This incident affected: Payment Products (Accept Payment).