LT_Swedbank elevated error rate

Incident Report for Mastercard OB Services EU and UK

Resolved

We are seeing an elevated error rate on LT_Swedbank PIS operations. We are currently monitoring thesituation.
Posted Jun 03, 2026 - 10:44 UTC

Monitoring

We are seeing an elevated error rate on LT_Swedbank PIS operations. We are currently monitoring thesituation.
Posted Jun 03, 2026 - 10:00 UTC