FI Samlink PSD2 AIS and PIS are experiencing interruptions starting from 10:20AM UTC

Incident Report for Mastercard OB Services EU and UK

Resolved

FI Samlink PSD2 AIS and PIS are experiencing interruptions starting from 10:20AM UTC
Posted Mar 13, 2026 - 12:12 UTC

Monitoring

FI Samlink PSD2 AIS and PIS are experiencing interruptions starting from 10:20AM UTC
Posted Mar 13, 2026 - 10:55 UTC
This incident affected: Providers (Finland).