Outage in app.aiia.eu

Incident Report for Mastercard OB Services EU and UK

Resolved

The DNS configuration as been fixed. Incident solved
Posted Apr 21, 2026 - 13:45 UTC

Investigating

Ongoing outage in app.aiia.eu
Posted Apr 21, 2026 - 13:05 UTC
This incident affected: Aiia (Aiia Pay).