Service degradation affecting PIS requests

Incident Report for Mastercard OB Services EU and UK

Resolved

From 08:10 am CET to 08:27 am CET Duration: 17 mins

The incident has been resolved now
Posted Apr 21, 2026 - 06:38 UTC

Investigating

We have identified an issue with our cloud provider affecting all PIS requests. We are investigating
Posted Apr 21, 2026 - 06:29 UTC
This incident affected: Payment Products (Accept Payment) and Aiia Enterprise (Payment initiation services).