Outage on all call types with Aktia in Finland

Incident Report for Mastercard OB Services EU and UK

Resolved

We are experiencing an outage with Aktia based providers in Finland. All call types are affected.
Posted Oct 21, 2025 - 07:29 UTC

Update

We are experiencing an outage with Aktia based providers in Finland. All call types are affected.
Posted Oct 20, 2025 - 16:40 UTC

Monitoring

We are experiencing an outage with Aktia based providers in Finland. All call types are affected.
Posted Oct 20, 2025 - 09:01 UTC