Nordea maintenance between 6th and 7th of August

Scheduled for Aug 6, 08:00 - 23:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 04, 2026 - 11:30 UTC

Scheduled

Please be informed that Nordea will perform maintenance on their Open Banking platform between 6th of August 2026 10:00 PM and 7th of August 2026 01:00 AM CEST.
All customers located in all countries may be affected and face issues while using our APIs.
Posted Aug 04, 2026 - 11:30 UTC
This scheduled maintenance affects: Providers (Denmark, Sweden, Norway, Finland).