DeutscheBank, Norisbank, Postbank - outage

Incident Report for Mastercard OB Services EU and UK

Resolved

We are currently investigating an issue with Deutsche Bank, Norisbank, Postbank providers with major outage detected from live traffic from 14:15hs (CET).
Posted Jul 24, 2026 - 11:39 UTC

Update

We are currently investigating an issue with Deutsche Bank, Norisbank, Postbank providers with major outage detected from live traffic from 14:15hs (CET).
Posted Jul 23, 2026 - 13:51 UTC

Investigating

We are currently investigating an issue with Deutsche Bank, Norisbank, Postbank providers with partial instabilities detected from live traffic.
Posted Jul 23, 2026 - 13:15 UTC