Cedacri group scheduled maintenance

Scheduled for Mar 26, 17:00 - 21:00 UTC

Update

Due to ordinary maintenance activities the Cedacri PSD2 APIs (Production) may be temporarily unavailable on Thursday, March 26th, from 06:00 p.m. (GMT +1) to 11:00 p.m. (GMT +1).
Posted Mar 24, 2026 - 10:03 UTC

Scheduled

Due to ordinary maintenance activities the Cedacri PSD2 APIs (Production) may be temporarily unavailable on Thursday, March 26th, from 06:00 p.m. (GMT +1) to 11:00 p.m. (GMT +1).
Posted Mar 20, 2026 - 09:48 UTC
This scheduled maintenance affects: Providers (Italy).