Unexpected outage with MitID

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 13:31 UTC

Investigating

We noticed authentication issues with providers on Danish market. It seems to be MitID-related issue. We are investigating it.
Posted Feb 27, 2026 - 10:24 UTC
This incident affected: Aiia Enterprise (Account information services).