Elevated errors for Luminor Lithuania

Incident Report for Mastercard OB Services EU and UK

Resolved

The issue has been resolved on the Luminor's side.
Posted Sep 15, 2026 - 12:07 UTC

Monitoring

Luminor Lithuania reported that they are experiencing issues with their PSD2 services.
Posted Sep 15, 2026 - 09:51 UTC
This incident affected: Providers (Lithuania).