Degraded performance for Aiia Pay customers

Incident Report for Mastercard OB Services EU and UK

Resolved

Impact end time - 11:20 UTC
Posted Apr 22, 2026 - 11:30 UTC

Update

Our engineering teams continue to investigate and are working on restoring the service.
Posted Apr 22, 2026 - 09:42 UTC

Update

We are observing failures affecting Aiia Pay clients. End users may encounter a blank page when initiating a payment flow.

Our engineering teams are actively investigating the root cause and working on restoring healthy service.
Posted Apr 22, 2026 - 08:10 UTC

Investigating

We are observing degraded performance affecting the Lithuania market. Users may experience failures when accessing affected services.
Posted Apr 22, 2026 - 07:26 UTC
This incident affected: Aiia (Aiia Pay).