Elevated error rates on PIS calls with Aktia

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved
Posted Sep 28, 2023 - 08:48 UTC

Identified

The issue is under investigation by the provider. We are waiting for their response
Posted Aug 09, 2023 - 08:21 UTC

Update

We are continuing to investigate this issue.
Posted Jul 20, 2023 - 13:31 UTC

Investigating

We are seeing elevated error rates on PIS calls with Aktia in Finland. We are contacting the provider.
Posted Jul 18, 2023 - 09:20 UTC
This incident affected: Providers (Finland).