Elevated error rates with Atruvia based providers in Germany

Incident Report for Mastercard OB Services EU and UK

Resolved

The fix has been verified. Incident resolved
Posted Aug 08, 2025 - 10:24 UTC

Monitoring

Since last Friday 1st August we are observing failed authentication requests for SecureGo plus in Atruvia based providers. We are working on a fix that will be released in the coming days

Update: The fix has been released. We are monitoring.
Posted Aug 07, 2025 - 11:37 UTC

Investigating

Since last Friday 1st August we are observing failed authentication requests for SecureGo plus in Atruvia based providers. We are working on a fix that will be released in the coming days
Posted Aug 06, 2025 - 08:07 UTC