Decreased conversion rate for Deutsche Kredit Bank

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 06:24 UTC

Monitoring

Starting at 15:30 CEST we start to observe successful traffic. Will continue monitoring
Posted Jul 03, 2026 - 14:11 UTC

Investigating

Starting at 14:15 CEST, we have observed an elevated error rate on Deutsche Kredit Bank PIS requests affecting conversion rate.

We are currently monitoring the traffic
Posted Jul 03, 2026 - 13:22 UTC
This incident affected: Providers (Germany).