Elevated error rates on all call types with Handelsbanken in Finland
Incident Report for Aiia
Resolved
We are seeing elevated error rates affecting many calls with Handelsbanken in Finland. All call types are affected.
Posted Apr 15, 2024 - 14:16 UTC
Investigating
We are seeing elevated error rates affecting many calls with Handelsbanken in Finland. All call types are affected.
Posted Apr 15, 2024 - 13:16 UTC
This incident affected: Providers (Finland).