Technical issues possible for Nordea in Sweden, Norway, Denmark and Finland
Incident Report for Aiia
Resolved
This incident has been resolved.
Posted Oct 30, 2024 - 12:00 UTC
Investigating
Please be informed that the Account Information System (AIS) for Nordea in Sweden, Norway, Denmark and Finland are facing technical problems.
Posted Oct 28, 2024 - 10:26 UTC
This incident affected: Aiia Enterprise (Account information services) and Providers (Denmark, Sweden, Norway, Finland).