Skandia scheduled maintenance

Scheduled for Aug 4, 05:30 - 07:00 UTC

Update

Skandia has reported the maintenance which will take place on 4th August from 07:30AM to 09:00AM CEST
Posted Jul 31, 2026 - 14:32 UTC

Scheduled

Skandia has reported the maintenance which will take place on 4th August from 07:30AM to 09:00AM CEST
Posted Jul 31, 2026 - 14:30 UTC
This scheduled maintenance affects: Providers (Sweden).