Elevated error rates on all call types with Luminor in Lithuania

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 09:04 UTC

Investigating

We are seeing elevated error rates affecting many calls with Luminor in Lithuania. All call types are affected.
Posted Aug 01, 2025 - 07:14 UTC
This incident affected: Providers (Lithuania).