Deutsche Bank, Norisbank, Postbank major outage

Incident Report for Mastercard OB Services EU and UK

Resolved

UPDATE: Banks/Providers started serving successful traffic since 08:00 AM (CET) getting back to normal.
Posted Jul 24, 2026 - 11:40 UTC

Identified

We are currently investigating an issue with Deutsche Bank, Norisbank, Postbank providers having major outage detected from live traffic from 14:15hs (CET).
Posted Jul 23, 2026 - 14:01 UTC