Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 14, 2025 - 01:00 UTC
Scheduled
Effective 17 March 2025, American Express has chosen to restrict access of PSD2 APIs to only include France and the United Kingdom. This means that providers SE_AmericanExpress and FI_AmericanExpress will be disabled for all clients on 14 March 2025 and subsequently deleted.
American Express have informed us, that the decision is made on the basis that Customer Accounts in EU countries other than France and the United Kingdom do not qualify as ‘payment accounts’ under PSD2. Consequently, any American Express API suite services provided in countries other than France and United Kingdom had been so far rendered voluntarily by American Express, who had no legal obligation under PSD2 to provide them.
Posted Jan 07, 2025 - 11:31 UTC
This scheduled maintenance affected: Providers (Sweden, Finland).